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1. Introduction

This FAQ provides information on setting up and troubleshooting QTRAK to use Word Integration
and eCorrespondence.

2. Word Integration
2.1. How to Setup this feature
2.2. How to Use this feature
2.3. Troubleshooting

3. eCorrespondence
3.1. How to Setup this feature
3.2. How to Use this feature
3.3. Troubleshooting

2. Word Integration

This feature allows QTRAK users to make use of the powerful features of MS Word for all their
correspondences. This gives QTRAK an edge over other products to be flexible enough for
integration and allows users to stick to their favourite word processor for daily needs. The
decision to use MS Word as an editor is made on per Mail Type per Project basis and applies to
all users within the project.

You need to have Word Templates for all the Mail Types available in your QTRAK application
directory C:\\QASOFT\QTRAK, where C: is the drive volume where QTRAK is installed. Please
refer FAQ-tr-003 on “How to Create MS Word Templates for Mail”, for assistance. As a guiding
example for this FAQ, we will use Mail Type as “Letter” which is the most common Mail Type for
using Word Integration.

2.1. How to setup

Please follow the steps mentioned below:

Launch QTRAK Application.

Login to any project with a username, which has administrative rights.

Select Mail Rules from Tools menu item. Click Tools->Mail Type Rules

In the Mail Type Rules window, select Letter

Double click Letter Mail Type

Select Letter Mail Type and click ‘Edit’ button on the toolbar at the top

In Edit Mail Type Rules window, select ‘Workflow’ tab

In bottom left corner, in ‘Formatting for outgoing mail:’ select ‘Use MSWord’ option

Click the ellipse button, ' = |, next to ‘Set Password for Word Templates:’
In the Password window, enter password set for the word template by you.
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NOTE: general advise is to use ‘gtrak’ as your password, as it is easy in case you forget the
password and QA needs to retrieve it for you. Or in some case you might have created some
parts of the template sent to QA for finish or QA might have prepared the templates for you as
part of order or customisation. In these circumstances it is easy to keep a standard..
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§ Re-Enter password
8 Click OK button
§ Click Close button on ‘Mail Type Rules’ window

You are done setting up the Word Integration feature with Mail Type ‘Letter’. In same way you can
follow the above-mentioned steps to setup ‘Word Integration’ for other Mail Types.
Now proceed with section 2.2.

2.2. How to Use

Launch QTRAK Application.

Login to any project with a username, which has administrative rights.

Open MDR from ‘Favourites’ pane on left hand side of the Dashboard or Select the option
‘Master Document Register’ from ‘View' menu.

Click New->Letter

Select ‘Addressee’ from the address book and click Ok

Enter ‘Subject’ of the Letter and Click ‘Save’ to save the document.

NOTE: it is compulsory to save the document before launching the Word Integration.

Click "Launch Microsoft Word’ to launch MS Word.

You will notice that all the details of the Mail type have been entered for you as designed in
your template.

You can enter the details of the letter and finish.

Close the Word document when you are done to return to QTRAK

Click close to return to MDR.
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NOTE: The Body text typed in Word is copied automatically back into QTRAK (minus the
formatting) to enhance search capabilities later.

2.3. Troubleshooting

Problem 1:
Password mismatch

Cause:
The below message is the most common error message that occurs, when QTRAK is unable to
automate word.

QTRAK - M5 Word Integration 5'

QTRAK cannok open the word template associat=d wikh this mail bype as there is a
problem with the assigred passward.
Please contack your syskem administratar or Q8 softbware For assistance,

Please refer '"CQASOFTIOTRAK EFror, LOG' error lag Far more details,

This error dialog is self-explanatory. This error happens when you have setup a different
password in QTRAK than the one you have in your MS word template.
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Solution:
Follow the below mentioned steps to reset the password in QTRAK:
- Select Mail Rules from Tools menu item. Click Tools->Mail Type Rules
In the Mail Type Rules window, select Letter
Select Letter Mail Type and click ‘Edit’ button on the toolbar at the top
In Edit Mail Type Rules window, select ‘Workflow’ tab

Click the ellipse button, ' |, next to ‘Set Password for Word Templates:’

In the Password window, enter password set for the word template by you. NOTE: The
password needs to be the exact password you have setup for the template. If QA software
provided the templates for you then please set the password as ‘gtrak’. Also note that the
passwords are case sensitive.

Re-Enter password

Click OK button

Click Close button on ‘Mail Type Rules’ window.

Try launching the mail template again

Problem 2:
Template formatting or data changes are not reflected for existing documents when using the
Word integration from QTRAK, but are visible outside QTRAK in the physical template file.

Cause:

QTRAK preserves a link to all MS Word documents, when they are created for the first time.
Sometimes clients after using the templates for the first time make some changes to templates, in
term of data displayed or format of the data, to make the templates more adaptable. These
changes are not reflected in the existing documents. The reason for this is that the link file has not
been updated.

Solution:

Delete the link file with old data and formatting and create the link file again by using the new
template. NOTE: Data in the particular MAIL Document is not lost as result of deleting the link file
as data is preserved internally in QTRAK and loaded on the fly when the Word Integration feature
is used. Follow below mentioned steps to delete the word link file:

Backup QTRAK application folder i.e. C:\QASOFT\QTRAK where C: is the drive volume where
QTRAK is installed

Select and open the desired project folder. For eg. If it is ‘DEMO’ project than the path is
C\QASOFT\QTRAK\PROJECTS\DEMO

Select and Delete the folder ‘Wordlink’.

Launch QTRAK and check the Mail document again by using word integration to see if the
changes are reflected.
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3. eCorrespondence

This feature, as the name suggest, allows the user to manage correspondence from QTRAK
using their default email client. QTRAK supports most of the major mail clients like MS Outlook,
Outlook Express, Lotus Notes & Novell Group wise. By using the eCorrespondence feature the
user can send correspondence from QTRAK through his/her email client and also import
correspondence from email client into QTRAK. QA software advises user to use MS Outlook as
their email client when considering MS Outlook & Outlook Express.

3.1. How to Setup
§ Setup your email client in QTRAK
a. Select ‘Options’ from ‘Tools’ menu
b. Select ‘Program Defaults’ tab
c. In the bottom left section select ‘Email Client:” and set it as ‘Other’ for MS Outlook
and Outlook Express. For others select the options accordingly.
d. Click ‘Save’ and ‘Close’ to return to Dashboard

§ Setup default email client through Internet Explorer (IE)
a. Launch Internet Explorer
b. Click ‘Tools’ ->'Internet Options’. Select ‘Programs’ tab
c. Select your Email client from the drop down.

General | Secunty | Privacy | Content | Connections | Programs | Advanced

Intemet programs

%4 You can specify which program Windows automatically uses
é&}} for each Intemet service,

HTML editor: | Microsoft CFfice Ward i
E-rnail: Microsaft Office Dutloak v
. |Hokmail

Newsgroups: Laotus Mates

Micrasaft Office Cutloak,
Internet call  jsn Explorer

Cutlook Express
Calendar: Micrasoft OFfice Cutlaak R
Corntact list: Microsoft OFfice Cutlook hd

[ Reset web Seftings... ] Y'ou can reset Internet Explorer to the default

home and search pages.

[ v Add- Enable or dizable browser add-ons installed on
anage s pour computer.

Intemet Explorer should check to see whether it is the default browser

[ (] ] [ Cancel

d. Click ok. Close IE window
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3.2. How to Use
§ Import emails from Outlook
a. Select ‘Import Email’ option from ‘eCorrespondence’ menu
b. Click ‘Refresh’ in the ‘Import Email’ window
c. When ask about program trying to access email client, say ‘yes’ and give access
for 10 min.
d. QTRAK will import all the emails and also give a list of the ones, which couldn’t be
imported.

8 Sending Emails from Outlook Correspondence Register
a. Open the mail document that you would like to send as Email.
b. From the toolbar select ‘Email report’
c. Select the recipients from the QTRAK address book and click send.
d. Click ‘'yes’ when asked about the security of the email client

3.3. Troubleshooting

Problem 1:
PDF printer driver when sending an email via eCorrespondence.

IEES=a) _ .
= Printing document to POF,
e 88 0®d T TR o B |
gy Reply &l Foraesed hwr-'lal ?askLﬂt Ccmar:!s \.-'Iew Flner Sﬁerl:h Hn‘tLIﬂ Prlrl Cloze

FMd To Type Tm
e-mail oulpet Cl cl L ¥

6 £n unexpacted error occurred whits printing Microsoft \Word document to FOF,

fr CAD-RC (ohne Tustzliche Lizent) ABO O Please refar W QASOFT\OTRAK\Error LOG' arror bog For nore detals,

1 wth LETTER DOT cl el
dem for HELP sccess and QYW Probiem in ATRA PS

]-IEEDDIDIIIIQD( - =

Aftachments

< B0E
' Send e-Cnrrespnnrie nce

IBG

Select Reclplents:
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“Joe Bloe |bloe@ga-softwarecom ¥
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Cause:

This problem is most common and happens if the PDF printer driver is not installed for QTRAK.
When sending mail through eCorrespondence, QTRAK converts the mail into a PDF file and
sends it as an attachment. For this QTRAK needs the PDF printer driver installed on the system.
The PDF printer driver is available for installation when QTRAK is installed. It needs to be
installed manually and is not installed automatically with QTRAK. Once installed QTRAK uses the
PDF driver to convert mails to PDF.
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Solution:

Please follow below mentioned steps to install the PDF printer driver.

§ Locate the folder C:\Program Files\QA Software\System using windows explorer
§ Locate and Double click file ‘install.bat’ or ‘install.exe’

8 Click Ok on the screen, which says ‘Printer driver installed’

§ Check for the printer in printers section by selecting START->Settings->Printers

Note: The above requires administrative access to your PC.

Problem:
Missing DllIs or control files when using Outlook Express as email client, an error dialog similar to
the one below is generated.

QDMS - eTransmittals E|
eTransmitkal generation aborted,
Zould not send the email For the Transmittal Mo &
In order to send/receive EMail vou need to have the Following components installed.
<MsMAPI3Z2,OC¥, MFc30.0LL, DlePro3z. DL, MsvortZ0,0LL, MPc40,DLL, MsWorks0,DLL =
Make sure you have the above files in wour Windows System Folder,

(Usually in Windows 9, this Folder will be <Rook:=:YWindows)System and
in Windaws BT, <Rook s WinkTSystem3z],

Cause:

This problem happens due to a missing Registry entry in the machine which refers MAPI activex
control, which is used by QTRAK for eCorrespondence. A registry patch is required to be installed
to solve this problem

Solution:

Please contact QA software for this registry patch.

Once you receive the pact please follow the steps mentioned below to install the MAPI patch.

§ Extract the attached zip file to a temp folder on C:\ drive say c:\temp

8 Double click to install the registry patch. Say yes when asked
NOTE: you will need administrative rights on the machine in order to install the patch.

8 Itis advisable that you inform your IT before installing the patch yourself or you can ask them
to do it for you.

4. Support
If any steps or solutions provided in the FAQ don’t change the problem or some other error, not
listed here, comes up contact QA Software at +61 3 8379 0000 or support@ga-software.com

Prepared by QA Software Page 6



